MRC AD322 DCC decoder

General:

I bought these at a closeout, just to "hold a place" in my USAT locos until the QSI comes out.

They were $11 from MRC.

8 amps, diesel sound (but not great prime mover sound), and supports advanced consisting. The manual states 3 accessory functions at 100 milliamps, but relates those to F1-F3 ??

Sound: long horn, short horn, bell, diesel idle and diesel rumble. The bell is OK, the horn is OK, the prime mover sound is like a defective blender. Certain sounds like the horn will turn off the prime mover sound. Definitely old technology.

They come with a 2 inch speaker.

Wiring:

Here is a link to the manual: AD322 manual

Here's also a link to an excellent page by Dave Bodnar: http://www.trainelectronics.com/MRC_DCC/index.html

2 plugs, the large one:

Red - right rail pickup
Black - left rail pickup
Orange - motor (will need to determine + or -)
Gray - motor
white - front light  (200 milliamps)
blue - common (plus)
yellow - back light (200 milliamps)

Smaller plug

Black - speaker - (8 ohms)
red - speaker +
brown - strobe light (100 ma?)
green - ditch light (100 ma?)
purple - ditch light (100 ma?)

All lights use the blue common. All lighting "outputs" are full track voltage. (The common is really positive like all DCC decoders)

There is a relay on the board that clicks when you reverse direction, good way to see if you are getting signal.

Programming:

When programming on the main, the decoder usually acknowledges by two short "jumps" forward on the track.

DCC functions:

F0 - headlight on/off
F1 - bell (toggle)
F2 - horn (toggle)
F3 - short horn (each time you hit F3)
F4 - coupler crash
F5 - ditch lights (toggle)
F8 - sound on off (horn and bell still function)

CV's supported:  range  shown, and default value in parens

1 - short address 1-127 (3)
2 - vstart  0-32 (0)
3 - accel rate 0-32 (0)
4 - decel rate - 0-32 (0)
5 - vhigh - 0-32 (0)
7 - manuf version number - 32
8 - manuf id
17 - extended address
18 - extended address
19 - consist address
29 - config - standard NMRA (2)
64 = 1 is normal lights, = 0 is rule 17 for ditch lights (1)
105 = user id number
106 = user id number

Tips:

  • The mute function is F8, but when you hit it, nothing happens UNTIL you honk the horn or ring the bell, after you release the horn or cycle the bell back off, the sound is muted. You can still honk and ring, but no diesel sounds. F4 works the same way.
  • Advanced consisting works fine, the default is to pass all the function commands to all units in consist. 
  • Sometimes, after consisting, the loco will not respond to it's long address, use the reset procedure below.
  • George Schreyer reports the PWM frequency is 250 Hz, so you will get some motor buzz, and that DC mode is unusable.  He also comments that replacing the 2" speaker is a good idea, even another 2" one performed better for him.
  • Jerry McColgan reports that the DC mode works fine if you switch to 14 speed step mode first. I have yet to verify this. I have disabled DC mode in all my decoders to avoid the dreaded "lockup" that sometimes destroys the decoder.
  • Occasionally these decoders get confused. Usually taking them off the tracks and back on will do the trick. Also coming to a stop and reversing and then back. These are not high end decoders, and there are obviously bugs in the firmware.
  • I had one unit in a consist run the wrong way, no matter what I did. It ran in the right direction outside of the consist. Performing the "reset" sequence below did the trick.

Reset:

These do not have a reset cv,you have to reset the following cv's to get things back to address # 3:
CV1=3 - set short address to 3
CV17=0 - set long address to 0 (high byte)
CV18=0 - set long address to 0 (low byte)
CV19=0 - reset consist address to 0
CV29=2 - normal direction,28/128 speed steps, no DC mode, standard speed table, use short address, set as loco decoder

On my NCE programming track, CV1 would often read back as 4, even when set to 3. On the tracks, it was indeed addressed to 3. Don't know if this is an AD322 problem, or I need to run a booster on my programming track. I have one, so will try it and report back.

If the decoder gets really confused, it can get stuck running backwards, or (my guess) destroy itself. I have 5 failed decoders, the most common failure is that the loco runs full speed all the time. It responds to direction, and the horn and bell can be controlled, but it goes full speed all the time. When this happens, you cannot recover it on the programming track. Two of my decoders had more spectacular failures, a loud pop and smoke. Mine destroyed a small electrolytic cap, George Schreyer had one of the voltage regulators burn up.

The manual states that double clicking F0, [lights] mutes the sounds. this does not work for me.

If you want to run without the sound, do not use any resistor in place of the speaker, you can run without the speaker and if space permits use the speaker with the sound off

Your system, [if it only has 14 speed steps] should automatically change cv # 29 to "4" during normal programming, but I strongly recommend turning off the analog operation if you do not need it. I think this will minimize erratic behavior.

CV 29 shortcuts:

28 ss, no DC mode, no speed tables, short addressing: = 2, = 3 for reversed direction

22 ss, no DC mode, no speed tables, long addressing: = 34, = 35 for reversed direction

 

 

Weather Underground PWS KCACARLS78