SD45 wiring errors

Unfortunately, the SD45, like many Aristo locos has wiring errors. Often the motors are wired to the wrong polarity, but worse in this case is that the socket pins that should control the headlights were not even connected.

I found this by the process of reversing the motor leads for the motor. In early versions of the QSI decoders would have a limitation in consisting if you reversed the motor direction in CV29. You never need to do this CV change unless the motor is wired backwards initially.

Explanation: Aristo only checks the locos under DC. To correct the loco direction, you can reverse the wires BEFORE the socket or AFTER the socket. If you do it before the socket, this still allows the motor wires to be backwards relative to the socket.

(Maybe this is why Aristo NEVER has forwards or backwards on their remotes, ya think? Just 2 arrows).

To get complete consisting functionality, and to just have the loco run correctly, I reversed the wires in the 6 pin connector shown below:

 

OK, so I was pretty happy with the simple fix.

Oops! now the lights were reversed.. Aristo apparently connected the headlights to the motor outputs, not to the dedicated pins in THEIR SOCKET.

So now I say, ok, wire to the socket.. wonder of wonders, NOTHING is connected to the socket pins!

So, you have to solder wires to the pins on the underside of the board for the front and rear headlights:

 

Dangerous miswire:

I found a really weird problem, took the last production SD45 (last thing Aristo manufactured), did not follow my own advice, threw a decoder in it and it went nuts:

Found that the small boards in the truck "A frames" were wired wrong, swapping a motor lead and a track pickup lead. Now since on DC these 2 are shorted together (one rail to one motor lead, the other rail to the other motor lead) under DC no issue... but under DCC, normally you destroy the decoder.

 

sd45 miswire

 

P1020134

Weather Underground PWS KCACARLS78